Degraded Performance

Incident Report for Procurify

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 12:42 PDT

Investigating

We are investigating degraded performance of our services.
Our team is currently working to restore.

We apologize for any inconvenience caused.
We will provide another updated in 15 minutes.
Thank you for your understanding.
Posted Oct 23, 2025 - 12:01 PDT
This incident affected: Web Application, Mobile Applications, Spending Card, AP Automation, Bill Payments, Notifications, Data Management, Login/SSO, Accounting Integrations, PunchOuts, and Spend Insights.