Spending Card Outage
Incident Report for Procurify
Resolved
This incident has been resolved. All systems are operational. Thank you for your understanding.
Posted Jul 28, 2022 - 16:50 PDT
Monitoring
Between 15:29 and 15:50 PST on Thursday, July 28 2022, Spending Card services were unavailable. We have identified and fixed the issue. We will continue to monitor our Spending Card services. Thank you for your understanding.
Posted Jul 28, 2022 - 16:31 PDT
This incident affected: Web Application, Mobile Applications, and Spending Card.