Degraded Performance

Incident Report for Procurify

Resolved

Our fix has been deployed and performance has returned to normal, thank you for your patience
Posted Jun 02, 2022 - 16:42 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 02, 2022 - 15:45 PDT

Monitoring

We have deployed a fix for our degraded performance and are monitoring the solution
Posted Jun 02, 2022 - 14:33 PDT

Identified

The cause of our degraded performance has been identified and a fix is being implemented
Posted Jun 02, 2022 - 12:37 PDT

Investigating

We are currently investigating degraded performance across our Product where customers are seeing slow loading times
Posted Jun 02, 2022 - 12:20 PDT
This incident affected: Web Application.