Issue with PunchOuts for Amazon Business
Incident Report for Procurify
Resolved
Intermittent outages have been resolved for Amazon Business PunchOuts
Posted Apr 06, 2023 - 17:59 PDT
Monitoring
We've identified that Amazon Business is having intermittent Service outages for PunchOuts and customers may experience errors when attempting to enter their portal. We'll monitor the situation and hope they can resolve the issue soon.
Posted Apr 06, 2023 - 14:22 PDT
This incident affected: PunchOuts.