We have verified the performance fix in production, and are considering this incident resolved. Thank you for your patience.
Posted Oct 23, 2025 - 16:43 PDT
Update
Performance remains stable. We will update this incident again when we have verified the fix in production.
Posted Oct 23, 2025 - 15:49 PDT
Identified
We have identified the source of a periodic performance degradation. Performance has returned to normal, but the team continues to monitor while we work to deploy a fix.
Posted Oct 23, 2025 - 15:07 PDT
Update
We are continuing to investigate this issue.
Posted Oct 23, 2025 - 14:43 PDT
Investigating
We are investigating degraded performance of our services.
We apologize for any inconvenience caused. We will provide another update in 30 minutes. Thank you for your understanding.
Posted Oct 23, 2025 - 14:43 PDT
This incident affected: Web Application, Mobile Applications, Spending Card, AP Automation, Bill Payments, Notifications, Data Management, Login/SSO, Accounting Integrations, PunchOuts, and Spend Insights.