Spend Insights not loading

Incident Report for Procurify

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 05:29 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 03:14 PDT

Update

The Spend Insights feature is intermittently accessible. Our third-party partner is working toward a fix to restore service fully. We will provide an update whenever there is new information.
Posted Oct 20, 2025 - 23:53 PDT

Update

The third-party service is continuing to work on a fix for this issue. Users may be able to intermittently access Spend Insights.
Posted Oct 20, 2025 - 21:21 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 19:59 PDT

Update

The third-party service is continuing to work on a fix for this issue. Users may be able to intermittently access Spend Insights.
Posted Oct 20, 2025 - 18:59 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 17:26 PDT

Identified

We have identified an issue with a third-party service related to the ongoing AWS region outage. We will monitor the status of the affected third-party service and provide updates.
Posted Oct 20, 2025 - 16:57 PDT

Update

We have identified an issue with a third-party service related to the ongoing AWS region outage. We will monitor the status of the affected third-party service and provide updates.
Posted Oct 20, 2025 - 16:23 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 16:07 PDT

Investigating

We have identified an issue with a third-party service preventing users from accessing Spend Insights. We are working closely with the third-party service to restore functionality and will provide updates as available. Thank you.
Posted Oct 20, 2025 - 15:45 PDT
This incident affected: Spend Insights.