Service Outage
Incident Report for Procurify
Resolved
This incident has been resolved.
Posted Aug 02, 2021 - 10:01 PDT
Investigating
We’re experiencing a service outage with the Procurify Web Application. Our team is currently working to restore the service. We apologize for any inconvenience as users may be affected. Next update in 15 minutes.
Posted Aug 02, 2021 - 05:50 PDT
This incident affected: Procurify Web (Procurify Web Application).