Login fixed! Monitoring status!
Incident Report for Procurify
Resolved
This incident has been resolved.
Posted Oct 25, 2021 - 10:57 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2021 - 19:41 PDT
Investigating
We are experiencing problems with our login. If you are already logged in, please stay on, and avoid logging out. We are looking into this issue as we speak.
Posted Oct 24, 2021 - 19:16 PDT
This incident affected: Procurify Web (Procurify Web Application).