Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 16, 2024 - 10:00 PST
Scheduled
We will be undergoing Aurora MySQL Database maintenance at this time.
Posted Nov 16, 2024 - 10:00 PST
This scheduled maintenance affected: Web Application, Mobile Applications, Spending Card, AP Automation, Bill Payments, Notifications, Data Management, Login/SSO, Accounting Integrations, and PunchOuts.