Service Outage
Incident Report for Procurify
Resolved
This incident has been resolved.
Posted Sep 21, 2021 - 07:04 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 21, 2021 - 06:38 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2021 - 06:24 PDT
Investigating
We’re experiencing a service outage with the Procurify Web Application. Our team is currently working to restore the service. We apologize for any inconvenience as users may be affected.
Posted Sep 21, 2021 - 06:13 PDT
This incident affected: Procurify Web (Procurify Web Application).