Degraded Performance: All Services

Incident Report for Procurify

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 14:43 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 07, 2026 - 14:38 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 07, 2026 - 13:38 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 12:33 PDT

Update

We are continuing to investigate this issue.
Posted Apr 07, 2026 - 11:53 PDT

Update

We are continuing to investigate this issue.
Posted Apr 07, 2026 - 11:36 PDT

Investigating

We are investigating intermittent degraded performance across all services.
Our team is currently working to restore normal service.

We apologize for any inconvenience caused.
We will provide another update in 15 minutes.
Thank you for your understanding.
Posted Apr 07, 2026 - 11:04 PDT
This incident affected: Web Application, Mobile Applications, Spending Card, AP Automation, Bill Payments, Notifications, Data Management, Login/SSO, Accounting Integrations, PunchOuts, and Spend Insights.