Attachment Errors!
Incident Report for Procurify
Resolved
File server restored.
Posted Dec 07, 2021 - 15:25 PST
Monitoring
We are experiencing issues with our file server. Users may experience errors when uploading/downloading attachments, or if they are expecting attachments via emails. Thank you for your understanding.
Posted Dec 07, 2021 - 11:30 PST
This incident affected: Procurify Web (Procurify Web Application).