Spending Card issues
Incident Report for Procurify
Resolved
Our spending card infrastructure continues to be stable. Thank you for your understanding.
Posted Jun 01, 2022 - 16:56 PDT
Monitoring
Our spending card infrastructure is stable. We will continue to monitor.
Posted Jun 01, 2022 - 14:04 PDT
Investigating
We are investigating an intermittent issue with our spending card infrastructure which is affecting managing, loading funds, and transaction updates
Posted Jun 01, 2022 - 13:13 PDT
This incident affected: Web Application.