Service Outage

Incident Report for Procurify

Resolved

This incident has been resolved.
Posted Jun 06, 2022 - 17:31 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 06, 2022 - 17:21 PDT

Monitoring

We've identified the issue and the fix has been implemented. We are currently monitoring.
Posted Jun 06, 2022 - 17:19 PDT

Investigating

We are currently investigating an outage with Procurify.
Posted Jun 06, 2022 - 17:13 PDT
This incident affected: Web Application.