Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jul 27, 2023 - 21:55 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 27, 2023 - 19:00 PDT
Scheduled
Between 2023-07-27 19:00 PT and 2023-07-27 22:00 PT, database maintenance will be performed. The application will not be affected for most of the scheduled period. Thank you for your understanding.
Posted Jul 27, 2023 - 14:52 PDT
This scheduled maintenance affected: Web Application, Mobile Applications, Spending Card, AP Automation, Bill Payments, Notifications, Data Management, Login/SSO, Accounting Integrations, and PunchOuts.