Service Outage
Incident Report for Procurify
Resolved
This incident has been resolved.
Posted Sep 24, 2021 - 11:43 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 24, 2021 - 10:58 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 24, 2021 - 09:57 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 24, 2021 - 08:56 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2021 - 08:25 PDT
Investigating
We are currently investigating an issue in which Procurify is having outages/degradation issues.
Posted Sep 24, 2021 - 08:00 PDT
This incident affected: Procurify Web (Procurify Web Application).