Major Outage: Punchouts

Incident Report for Procurify

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 09:38 PDT

Update

This incident has been resolved. All Punchout suppliers are operational. Thank you for your understanding.
Posted Mar 17, 2026 - 09:37 PDT

Monitoring

We've identified the issue and taken the necessary steps to resolve the issue.

We will continue to monitor the situation and will provide another update in 15 minutes.
Posted Mar 17, 2026 - 09:20 PDT

Update

We are continuing to investigate the root cause of the punchout outage.

Thank you for your patience.
Posted Mar 17, 2026 - 09:08 PDT

Update

We are continuing to investigate the root cause of the punchout outage.

Thank you for your patience.
Posted Mar 17, 2026 - 08:45 PDT

Investigating

We are investigating a major outage for our punchout service. Our team is currently working to restore the service. This outage affects:
• Amazon Punchout
• McKesson Punchout
• Staples Punchout

We apologize for any inconvenience caused.
We will provide another updated in 15 minutes.
Thank you for your understanding.
Posted Mar 17, 2026 - 08:16 PDT
This incident affected: PunchOuts.